Shutter Asia Forum

Shutter Asia Forum (http://www.shutterasia.com/forum/index.php)
-   Canon Equipment (http://www.shutterasia.com/forum/forumdisplay.php?f=19)
-   -   Help Needed On Canon EOS 20D (http://www.shutterasia.com/forum/showthread.php?t=1568)

mhafizahmad 06-03-2007 07:35 PM

Help Needed On Canon EOS 20D
 
Today, I borrow a 20D from my friend to shoot one of my wedding job.

After several shooting, the camera hang! It shows the battery is FULLY DRAINED! I try to switch it on and off again, but still the same. The battery is just been recharged.

Finally, the solution, I take out the battery grip, the lens and the flash and wait about 30sec and put it back on the camera, and the camera is going fine again.. but the thing keep on happen about 7 times!!!!

Luckily I have backup body that time... fuh...

Can anybody pls help me on this? What actually is happen? What kinda' malfunction it is?

Thank you.

Freaky 06-03-2007 09:41 PM

Sounds like battery problem to me...

Is that an original battery or 3rd party battery u using...

I have same prob with my 3rd party battery... Digicelll (blardy *@$@$*)

When charge, shows fully charge (green light) very fast, but battery not charged fully... So usually, i leave it in charger overnight.

But recently, it still doesn;t charge full and drains fast...

battery is fairly new, so i think from now on, i stick with originals...

This also happen to my video cam before, also battery die problem... fully charge, drain fast.

BTW, when u take batteries out of electronic stuff, and let them lie for a while, when u put them in the electronic device again, battery will be able to use again (for a while)... that is prob why u think it's a cam problem...

mhafizahmad 06-03-2007 09:45 PM

Already found the answer in Canon Malaysia website. It is becoz' of the manufacturer defect of the BG-E2, Canon will repair it free.

Thanks again.


Quote:

Originally Posted by Freaky (Post 15151)
Sounds like battery problem to me...

Is that an original battery or 3rd party battery u using...

I have same prob with my 3rd party battery... Digicelll (blardy *@$@$*)

When charge, shows fully charge (green light) very fast, but battery not charged fully... So usually, i leave it in charger overnight.

But recently, it still doesn;t charge full and drains fast...

battery is fairly new, so i think from now on, i stick with originals...

This also happen to my video cam before, also battery die problem... fully charge, drain fast.

BTW, when u take batteries out of electronic stuff, and let them lie for a while, when u put them in the electronic device again, battery will be able to use again (for a while)... that is prob why u think it's a cam problem...



All times are GMT +8. The time now is 10:32 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Site Content and Design Copyright 2007-2013 Shutter Asia - All Rights Reserved